Return to TheElectricBrewery.com
  [ Shop ]   [ Building ]   [ Using ]   [ Recipes ]   [ Testimonials ]   [ Gallery ]   [ FAQ ]   [ About Us ]   [ Contact Us ]   [ Newsletter ]

Log inLog in   RegisterRegister   User Control PanelUser Control Panel   Private MessagesPrivate Messages   MembershipClub Memberships   SearchSearch   MemberlistMemberlist   Photo AlbumsPhoto Albums   Forum FAQForum FAQ


HLT and BK elements not working

 
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products
View previous topic :: View next topic  
Author Message
BrandonsBasement




Joined: 07 Aug 2020
Posts: 2



PostLink    Posted: Fri Aug 07, 2020 1:36 pm    Post subject: HLT and BK elements not working Reply with quote


        Register to remove this ad. It's free!
Good morning! I'm hoping someone can push me in the right direction. All of the sudden, neither of the elements will power on. If I unplug either of the elements form the control panel and turn on the element, the ON light will come on. However, when I plug the element into the control panel, it does not come on (the light or the element).

Everything else is working as it should...

Any ideas?
Back to top
kal
Forum Administrator



Joined: 12 Dec 2010
Posts: 11034
Location: Ottawa, Canada

Drinking: Pub Ale, Electric Creamsicle, Mild, Pliny the Younger, Belgian Dark Strong, Weizen, Russian Imperial Stout, Black Butte Porter


PostLink    Posted: Fri Aug 07, 2020 2:01 pm    Post subject: Reply with quote

Hi and welcome to the forum!

Please see the troubleshooting tips here: http://www.theelectricbrewery.com/forum/viewtopic.php?t=25460

Specifically the section "My heating element is not firing at all! (or firing continuously)".
It'll walk you through step by step.

Kal

_________________
Our new shop with over 150 new products: shop.TheElectricBrewery.com
We ship worldwide and support our products and customers for life.
Purchasing through our affiliate links helps support our site at no extra cost to you. We thank you!
My basement/bar/brewery build 2.0
Back to top
View user's photo album (21 photos)
BrandonsBasement




Joined: 07 Aug 2020
Posts: 2



PostLink    Posted: Mon Aug 10, 2020 5:54 pm    Post subject: Reply with quote

So, a little self-deprecation here...

It's working as it should, I believe I started to heat some wort to a boil (it was in a fermentor souring, so I wasn't using all of the kettles). I got ahead of myself and never connected the temp probes, which started me down a troubleshooting spiral, without checking the obvious, first.
Back to top
kal
Forum Administrator



Joined: 12 Dec 2010
Posts: 11034
Location: Ottawa, Canada

Drinking: Pub Ale, Electric Creamsicle, Mild, Pliny the Younger, Belgian Dark Strong, Weizen, Russian Imperial Stout, Black Butte Porter


PostLink    Posted: Mon Aug 10, 2020 5:58 pm    Post subject: Reply with quote

Always best when it's something simple!

Kal

_________________
Our new shop with over 150 new products: shop.TheElectricBrewery.com
We ship worldwide and support our products and customers for life.
Purchasing through our affiliate links helps support our site at no extra cost to you. We thank you!
My basement/bar/brewery build 2.0
Back to top
View user's photo album (21 photos)
Display posts from previous:   
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products All times are GMT
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Support our site by purchasing through this link. We thank you!

Forum powered by phpBB © phpBB Group