Return to TheElectricBrewery.com
  [ Shop ]   [ Building ]   [ Using ]   [ Recipes ]   [ Testimonials ]   [ Gallery ]   [ FAQ ]   [ About Us ]   [ Contact Us ]   [ Newsletter ]

Log inLog in   RegisterRegister   User Control PanelUser Control Panel   Private MessagesPrivate Messages   MembershipClub Memberships   SearchSearch   MemberlistMemberlist   Photo AlbumsPhoto Albums   Forum FAQForum FAQ


Control Panel Question

 
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products
View previous topic :: View next topic  
Author Message
daboyce67



Joined: 15 Aug 2014
Posts: 43
Location: Hayward, Wisconsin


PostLink    Posted: Fri Oct 13, 2017 8:00 pm    Post subject: Control Panel Question Reply with quote


        Register to remove this ad. It's free!
Was cleaning out some hoses on my system. Cycling hot water and PBW from the HLT thru the pump to clean the hoses. All done. Turned the Control Panel off and let the HLT's water cool down. Came back later with the intent of pumping out the HLT, turned the Control Panel switch and nothing. Dead. No lights, no anything. I'm an electrical nabob so put a call in to my electrician - waiting to hear back from him to schedule a visit.

The GFCI won't reset. So I pulled the Control Panel power cord from outlet and the GFCI still won't reset. Is it safe to say the issue is with the GFCI circuit breaker? Again, forgive my ignorance, sort of shooting in the dark here. But, if the Control Panel is not plugged in am I correct in assuming there's no load on that circuit? And, if so, if it still won't reset, can you think of any other cause?

Thanks.
Back to top
daboyce67



Joined: 15 Aug 2014
Posts: 43
Location: Hayward, Wisconsin


PostLink    Posted: Fri Oct 13, 2017 8:30 pm    Post subject: Reply with quote

Ok, as a followup it appears the GFCI breaker is functioning fine. It is not tripping but when tested functions as it should. So, the new question is why would the Control Panel all of a sudden not function at all, i.e. dead when I turn the key to "on"? Anyone think of anything I can/should immediately check?
Back to top
Tennessee



Joined: 04 Apr 2015
Posts: 112
Location: Tennessee


PostLink    Posted: Fri Oct 13, 2017 10:33 pm    Post subject: Reply with quote

Are all your switches turned to the "OFF" position ?

Safety Interlock Switch

http://www.theelectricbrewery.com/control-panel-safe-start-interlock

_________________
Kal Clone (30amp),Mash Re-Circulation Manifold, Custom BK Hop Filter.
Back to top
daboyce67



Joined: 15 Aug 2014
Posts: 43
Location: Hayward, Wisconsin


PostLink    Posted: Fri Oct 13, 2017 10:44 pm    Post subject: Reply with quote

Tennessee,

Thanks - that was it. Even though I had disconnected all the cords and turned off (what I thought were all the switches) the HLT element switch was still in the on position. Bingo. Damn, I love this forum. Thanks again.
Back to top
Display posts from previous:   
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products All times are GMT
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Support our site by purchasing through this link. We thank you!

Forum powered by phpBB © phpBB Group