Return to TheElectricBrewery.com
  [ Shop ]   [ Building ]   [ Using ]   [ Recipes ]   [ Testimonials ]   [ Gallery ]   [ FAQ ]   [ About Us ]   [ Contact Us ]   [ Newsletter ]

Log inLog in   RegisterRegister   User Control PanelUser Control Panel   Private MessagesPrivate Messages   MembershipClub Memberships   SearchSearch   MemberlistMemberlist   Photo AlbumsPhoto Albums   Forum FAQForum FAQ

Boil Element troubleshooting

 
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products
View previous topic :: View next topic  
Author Message
BruddahBrewing



Joined: 09 Feb 2016
Posts: 3
Location: San Francisco, CA


PostLink    Posted: Fri Jul 14, 2017 4:48 am    Post subject: Boil Element troubleshooting Reply with quote


        Register to remove this ad. It's free!
Hi, I am looking for a little direction in troubleshooting why my boil element is not working.

I purchased a preassembled 50 amp panel that I have converted to use 240 VAC single phase. I purchased the necessary items from spike which essentially meant some solid-state relays and changed all the lights according to the directions on the website. The panel powers up and everything seems to work including the hot liquor tank elements and light but the boil elements and light do not work. I do hear the relay clicking when turning on the boil element switch but the light and the element get no power. I checked and it seems that the output from the relay is deficient when switching to boil. It may be because of something that the relay is connected to. Any insight on how I can effectively troubleshoot this? Any input would be greatly appreciated. Thanks!

Philip J. Krueger

_________________
The best way to predict the future is to invent it
Back to top
kal
Forum Administrator


Joined: 12 Dec 2010
Posts: 9886
Location: Ottawa, Canada

Drinking: German Lager, Electric Hop Candy Jr, Scottish 70/-, Cali Common, Maibock, Helles, Russian Imperial Stout, Black Butte Porter

Working on: Weizen


PostLink    Posted: Fri Jul 14, 2017 12:04 pm    Post subject: Reply with quote

Hi Philip,

Check out our troubleshooting thread here: http://www.theelectricbrewery.com/forum/viewtopic.php?t=25460

Specifically the section "My heating element is not firing at all! (or firing continuously)".

It may just be a PID configuration/usage problem. The boil PID is usually configured to run in both manual and auto modes while the HLT is configured to run in auto only. This causes confusion sometimes - the link above will walk you through what buttons to press on the boil PID to get it to work as you expect. Good luck!

Kal

_________________
Our new shop with over 150 new products: shop.TheElectricBrewery.com
Purchasing through our affiliate links helps support our site at no extra cost to you. We thank you!
My basement/bar/brewery build 2.0
Back to top
View user's photo album (21 photos)
kal
Forum Administrator


Joined: 12 Dec 2010
Posts: 9886
Location: Ottawa, Canada

Drinking: German Lager, Electric Hop Candy Jr, Scottish 70/-, Cali Common, Maibock, Helles, Russian Imperial Stout, Black Butte Porter

Working on: Weizen


PostLink    Posted: Tue Jul 18, 2017 1:48 pm    Post subject: Reply with quote

Problem solved. To close the loop - it was a boil PID setting / usage issue. Happy brewing!

KAl

_________________
Our new shop with over 150 new products: shop.TheElectricBrewery.com
Purchasing through our affiliate links helps support our site at no extra cost to you. We thank you!
My basement/bar/brewery build 2.0
Back to top
View user's photo album (21 photos)
Display posts from previous:   
Post new topic   Reply to topic   Printer-friendly view    TheElectricBrewery.com Forum Index -> TheElectricBrewery.com Products All times are GMT
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Support our site by purchasing through this link. We thank you!

Forum powered by phpBB © phpBB Group